summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Matteo Bernardini2014-08-22 17:43:47 +0200
committer Matteo Bernardini2014-08-22 17:43:47 +0200
commit88a27c19bfbd4bafef50ba2cb167b671fe409e53 (patch)
tree2d2972d399db1728c07c2c89c7efbe53a98c3079 /audio
parentc1916c8b21c893da6e93245ec22af95574ab4c24 (diff)
downloadold.slackbuilds-88a27c19bfbd4bafef50ba2cb167b671fe409e53.tar.gz
20140822.1 global branch merge.current-20140822.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/SAM/README8
-rw-r--r--audio/SAM/SAM.SlackBuild89
-rw-r--r--audio/SAM/SAM.info10
-rw-r--r--audio/SAM/slack-desc19
-rw-r--r--audio/TiMidity++/TiMidity++.SlackBuild4
-rw-r--r--audio/audacity/README2
-rw-r--r--audio/audacity/audacity.SlackBuild4
-rw-r--r--audio/audacity/audacity.info6
-rw-r--r--audio/jack-audio-connection-kit/jack-audio-connection-kit.SlackBuild6
-rw-r--r--audio/mixxx/mixxx.SlackBuild12
-rw-r--r--audio/mixxx/mixxx.info8
-rw-r--r--audio/vamp-plugin-sdk/vamp-plugin-sdk.SlackBuild7
12 files changed, 157 insertions, 18 deletions
diff --git a/audio/SAM/README b/audio/SAM/README
new file mode 100644
index 0000000000..184eaee3ba
--- /dev/null
+++ b/audio/SAM/README
@@ -0,0 +1,8 @@
+Sam is a very small Text-To-Speech (TTS) program written in C, that
+runs on most popular platforms.
+It is an adaption to C of the speech software SAM (Software Automatic
+Mouth) for the Commodore C64 published in the year 1982 by Don't Ask
+Software (now SoftVoice, Inc.).
+It includes a Text-To-Phoneme converter called reciter and a
+Phoneme-To-Speech routine for the final output.
+It is so small that it will work also on embedded computers.
diff --git a/audio/SAM/SAM.SlackBuild b/audio/SAM/SAM.SlackBuild
new file mode 100644
index 0000000000..19a338dc43
--- /dev/null
+++ b/audio/SAM/SAM.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for SAM
+
+# Copyright 2013 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=SAM
+VERSION=${VERSION:-20140302_66b3414}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Use our CFLAGS
+sed -i "s|-O2|$SLKCFLAGS|" Makefile
+make
+install -D -m 0755 sam $PKG/usr/bin/sam
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md $PKG/usr/doc/$PRGNAM-$VERSION
+sed 's/.$//' sing > $PKG/usr/doc/$PRGNAM-$VERSION/sing
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/SAM/SAM.info b/audio/SAM/SAM.info
new file mode 100644
index 0000000000..6292d07c04
--- /dev/null
+++ b/audio/SAM/SAM.info
@@ -0,0 +1,10 @@
+PRGNAM="SAM"
+VERSION="20140302_66b3414"
+HOMEPAGE="https://github.com/s-macke/SAM"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/SAM-20140302_66b3414.tar.xz"
+MD5SUM="1725969b80d1e93cb7dfa18216bd4818"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Matteo Bernardini"
+EMAIL="ponce@slackbuilds.org"
diff --git a/audio/SAM/slack-desc b/audio/SAM/slack-desc
new file mode 100644
index 0000000000..d31ef3b855
--- /dev/null
+++ b/audio/SAM/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+SAM: SAM (Software Automatic Mouth)
+SAM:
+SAM: Sam is a very small Text-To-Speech (TTS) program written in C, that
+SAM: runs on most popular platforms.
+SAM: It is an adaption to C of the speech software SAM (Software Automatic
+SAM: Mouth) for the Commodore C64 published in the year 1982 by Don't Ask
+SAM: Software (now SoftVoice, Inc.).
+SAM: It includes a Text-To-Phoneme converter called reciter and a
+SAM: Phoneme-To-Speech routine for the final output.
+SAM: It is so small that it will work also on embedded computers.
+SAM:
diff --git a/audio/TiMidity++/TiMidity++.SlackBuild b/audio/TiMidity++/TiMidity++.SlackBuild
index 73c4c2d624..554f3af339 100644
--- a/audio/TiMidity++/TiMidity++.SlackBuild
+++ b/audio/TiMidity++/TiMidity++.SlackBuild
@@ -8,7 +8,7 @@
PRGNAM=TiMidity++
VERSION=2.14.0
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -92,7 +92,7 @@ patch -p0 < $CWD/timidity++-2.14.0-tcltk86.patch
# Regenerate files for automake/autoconf.
# Required for --docdir
-autoreconf
+autoreconf -vif
EXTRACFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/audio/audacity/README b/audio/audacity/README
index 9d84ab2542..4182770830 100644
--- a/audio/audacity/README
+++ b/audio/audacity/README
@@ -4,7 +4,7 @@ digital recordings, edit Ogg, MP3, and WAV sound files, and much more.
Support for optional dependencies can be enabled passing the script
optional parameters, such as:
-FFMPEG=yes (requires ffmpeg - BROKEN ATM)
+FFMPEG=yes (requires ffmpeg)
SOUNDTOUCH=yes (requires soundtouch)
TWOLAME=yes (requires twolame)
VAMP=yes (requires vamp-plugin-sdk)
diff --git a/audio/audacity/audacity.SlackBuild b/audio/audacity/audacity.SlackBuild
index 991355940d..ec9029251f 100644
--- a/audio/audacity/audacity.SlackBuild
+++ b/audio/audacity/audacity.SlackBuild
@@ -29,7 +29,7 @@
# Modified by the SlackBuilds.org project
PRGNAM=audacity
-VERSION=${VERSION:-2.0.5}
+VERSION=${VERSION:-r13299}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -98,7 +98,7 @@ CXXFLAGS="$SLKCFLAGS" \
--with-libflac \
--with-libsndfile \
--with-libid3tag \
- --with-libresample \
+ --with-libsoxr \
--with$do_ffmpeg-ffmpeg \
--with$do_soundtouch-soundtouch \
--with$do_twolame-libtwolame \
diff --git a/audio/audacity/audacity.info b/audio/audacity/audacity.info
index aec965310f..4675b8fd1b 100644
--- a/audio/audacity/audacity.info
+++ b/audio/audacity/audacity.info
@@ -1,8 +1,8 @@
PRGNAM="audacity"
-VERSION="2.0.5"
+VERSION="r13299"
HOMEPAGE="http://audacity.sourceforge.net"
-DOWNLOAD="http://audacity.googlecode.com/files/audacity-minsrc-2.0.5.tar.xz"
-MD5SUM="657f71a5a214fe84731ed9842e09fa04"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/audacity-minsrc-r13299.tar.xz"
+MD5SUM="16f44c59c97d74192806c78d48b9eb7e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="wxPython"
diff --git a/audio/jack-audio-connection-kit/jack-audio-connection-kit.SlackBuild b/audio/jack-audio-connection-kit/jack-audio-connection-kit.SlackBuild
index bbb62a4693..02c98f9559 100644
--- a/audio/jack-audio-connection-kit/jack-audio-connection-kit.SlackBuild
+++ b/audio/jack-audio-connection-kit/jack-audio-connection-kit.SlackBuild
@@ -27,7 +27,7 @@
PRGNAM=jack-audio-connection-kit
VERSION=${VERSION:-0.124.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,6 +72,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# respect march and mtune flags: fixes building on x86_64
+sed -i 's|-march=native \-mtune=native||' configure.ac
+autoreconf -fi
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/audio/mixxx/mixxx.SlackBuild b/audio/mixxx/mixxx.SlackBuild
index 44e0fce8d2..fc6c2565f4 100644
--- a/audio/mixxx/mixxx.SlackBuild
+++ b/audio/mixxx/mixxx.SlackBuild
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mixxx
-VERSION=${VERSION:-1.10.1}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.11.0}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,11 +72,15 @@ find -L . \
# Fix the desktop file
patch -p0 < $CWD/desktop.diff
-# it seems libshout isn't detected :(
+# Fix library installation path
+sed -i "s|lib/mixxx|lib$LIBDIRSUFFIX/mixxx|" build/depends.py
+sed -i "s|'lib'|'lib$LIBDIRSUFFIX'|" src/SConscript
+
CFLAGS="$SLKCFLAGS" \
QTDIR=/usr/lib$LIBDIRSUFFIX/qt \
scons \
- shoutcast=0 \
+ shoutcast=1 \
+ faad=1 \
prefix=/usr
QTDIR=/usr/lib$LIBDIRSUFFIX/qt \
diff --git a/audio/mixxx/mixxx.info b/audio/mixxx/mixxx.info
index e60b959071..4f98f179a2 100644
--- a/audio/mixxx/mixxx.info
+++ b/audio/mixxx/mixxx.info
@@ -1,10 +1,10 @@
PRGNAM="mixxx"
-VERSION="1.10.1"
+VERSION="1.11.0"
HOMEPAGE="http://www.mixxx.org"
-DOWNLOAD="http://downloads.mixxx.org/mixxx-1.10.1/mixxx-1.10.1-src.tar.gz"
-MD5SUM="765bc5216ec8102c2186dd3ea80187a9"
+DOWNLOAD="http://downloads.mixxx.org/mixxx-1.11.0/mixxx-1.11.0-src.tar.gz"
+MD5SUM="89ee8ba60824919d8dd1194287bda259"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="libshout portaudio portmidi scons"
+REQUIRES="faad libshout opencore portaudio portmidi scons"
MAINTAINER="Elvio Basello (HelLViS69)"
EMAIL="hellvis69@slackware.it"
diff --git a/audio/vamp-plugin-sdk/vamp-plugin-sdk.SlackBuild b/audio/vamp-plugin-sdk/vamp-plugin-sdk.SlackBuild
index b7dd2865aa..f4134862e9 100644
--- a/audio/vamp-plugin-sdk/vamp-plugin-sdk.SlackBuild
+++ b/audio/vamp-plugin-sdk/vamp-plugin-sdk.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=vamp-plugin-sdk
VERSION=${VERSION:-2.4}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -54,6 +54,8 @@ find -L . \
# Fix libdir on x86_64
[ "$ARCH" = "x86_64" ] && patch -p1 < $CWD/libdir_x86_64.diff
+# Explicitly link to libsndfile
+LIBS="-lsndfile" \
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -65,6 +67,9 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
+# These confuse our linker
+rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.la
+
mkdir -p $PKG/etc/profile.d/
cat << EOF > $PKG/etc/profile.d/vamp.csh
#!/bin/csh