summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2018-04-27 23:04:40 +0200
committer Willy Sudiarto Raharjo2018-04-28 01:40:13 +0200
commit59f3243379b19fa37d53590a613407bb93929cb6 (patch)
tree8a294909b05847f759254ed61e9f241c241a971f /academic
parentcd477d5969062db50c3ba592a5de439949579944 (diff)
downloadold.slackbuilds-59f3243379b19fa37d53590a613407bb93929cb6.tar.gz
academic/Shark: Added (machine learning library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/Shark/README8
-rw-r--r--academic/Shark/Shark.SlackBuild102
-rw-r--r--academic/Shark/Shark.info10
-rw-r--r--academic/Shark/slack-desc19
4 files changed, 139 insertions, 0 deletions
diff --git a/academic/Shark/README b/academic/Shark/README
new file mode 100644
index 0000000000..3f880796d1
--- /dev/null
+++ b/academic/Shark/README
@@ -0,0 +1,8 @@
+Shark is a fast, modular, feature-rich open-source C++ machine
+learning library. It provides methods for linear and nonlinear
+optimization, kernel-based learning algorithms, neural networks and
+various other machine learning techniques (see the feature list
+below). It serves as a powerful toolbox for real world applications
+as well as research. Shark depends on Boost and CMake.
+
+Optional dependencies: atlas, hdf5.
diff --git a/academic/Shark/Shark.SlackBuild b/academic/Shark/Shark.SlackBuild
new file mode 100644
index 0000000000..d7a328ef6c
--- /dev/null
+++ b/academic/Shark/Shark.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+
+# SlackBuild script for Shark
+
+# Copyright 2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Shark
+VERSION=${VERSION:-3.1.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s/\blib\b/lib${LIBDIRSUFFIX}/" CMakeLists.txt src/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_EXAMPLES=OFF \
+ -DBUILD_TESTING=OFF \
+ -DBUILD_SHARED_LIBS=ON \
+ ..
+
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/Shark/Shark.info b/academic/Shark/Shark.info
new file mode 100644
index 0000000000..1481221e0a
--- /dev/null
+++ b/academic/Shark/Shark.info
@@ -0,0 +1,10 @@
+PRGNAM="Shark"
+VERSION="3.1.4"
+HOMEPAGE="http://image.diku.dk/shark"
+DOWNLOAD="https://github.com/Shark-ML/Shark/archive/v3.1.4/Shark-3.1.4.tar.gz"
+MD5SUM="b6d3859050d7de9500841c7cebec87a3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/Shark/slack-desc b/academic/Shark/slack-desc
new file mode 100644
index 0000000000..015141daed
--- /dev/null
+++ b/academic/Shark/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Shark: Shark (machine learning library)
+Shark:
+Shark: Shark is a fast, modular, feature-rich open-source C++ machine
+Shark: learning library. It provides methods for linear and nonlinear
+Shark: optimization, kernel-based learning algorithms, neural networks and
+Shark: various other machine learning techniques (see the feature list
+Shark: below). It serves as a powerful toolbox for real world applications
+Shark: as well as research. Shark depends on Boost and CMake.
+Shark:
+Shark:
+Shark: