summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-02-24 12:02:29 +0100
committer Matteo Bernardini2018-06-09 08:41:52 +0200
commit2126a2767ef1b25b14a71fe65de96ced260f43ca (patch)
treea012ecd0c25a0610791ffa8a6c55a2bdc5651152
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-python-urllib3.tar.gz
python/python-urllib3: Removed (added to Slackware).python-urllib3
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python-urllib3/README12
-rw-r--r--python/python-urllib3/python-urllib3.SlackBuild89
-rw-r--r--python/python-urllib3/python-urllib3.info10
-rw-r--r--python/python-urllib3/slack-desc19
4 files changed, 0 insertions, 130 deletions
diff --git a/python/python-urllib3/README b/python/python-urllib3/README
deleted file mode 100644
index df9a0f529f..0000000000
--- a/python/python-urllib3/README
+++ /dev/null
@@ -1,12 +0,0 @@
-urllib3 is a powerful, sanity-friendly HTTP client for Python. Much of the Python
-ecosystem already uses urllib3 and you should too. urllib3 brings many critical features
-that are missing from the Python standard libraries:
-
-Thread safety.
-Connection pooling.
-Client-side SSL/TLS verification.
-File uploads with multipart encoding.
-Helpers for retrying requests and dealing with HTTP redirects.
-Support for gzip and deflate encoding.
-Proxy support for HTTP and SOCKS.
-100% test coverage.
diff --git a/python/python-urllib3/python-urllib3.SlackBuild b/python/python-urllib3/python-urllib3.SlackBuild
deleted file mode 100644
index d54723c12a..0000000000
--- a/python/python-urllib3/python-urllib3.SlackBuild
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-urllib3
-
-# Copyright 2013 Thibaut Notteboom, Paris, FRANCE
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-urllib3
-SRCNAM=$(echo $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-1.22}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.rst *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-urllib3/python-urllib3.info b/python/python-urllib3/python-urllib3.info
deleted file mode 100644
index 3a3d26b468..0000000000
--- a/python/python-urllib3/python-urllib3.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-urllib3"
-VERSION="1.22"
-HOMEPAGE="https://urllib3.readthedocs.io/en/latest/"
-DOWNLOAD="https://pypi.python.org/packages/ee/11/7c59620aceedcc1ef65e156cc5ce5a24ef87be4107c2b74458464e437a5d/urllib3-1.22.tar.gz"
-MD5SUM="0da7bed3fe94bf7dc59ae37885cc72f7"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-urllib3/slack-desc b/python/python-urllib3/slack-desc
deleted file mode 100644
index 90699d4267..0000000000
--- a/python/python-urllib3/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-urllib3: python-urllib3 (HTTP library)
-python-urllib3:
-python-urllib3: urllib3 is a powerful, sanity-friendly HTTP client for Python. Much
-python-urllib3: of the Python ecosystem already uses urllib3 and you should too.
-python-urllib3:
-python-urllib3: Homepage: https://urllib3.readthedocs.io/en/latest/
-python-urllib3:
-python-urllib3:
-python-urllib3:
-python-urllib3:
-python-urllib3: