summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-05-02 09:49:36 +0200
committer Matteo Bernardini2018-06-09 08:41:33 +0200
commitffcf164c277c24ff5321a92ed9c7aa8fa0c1cc01 (patch)
tree22bd6153896f3709dae0f956111abb54dc340ac3
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-python-gattlib.tar.gz
python/python-gattlib: Fix setup.py for the newer boost.python-gattlib
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python-gattlib/dont_hardcode_python_versions.patch19
-rw-r--r--python/python-gattlib/python-gattlib.SlackBuild2
2 files changed, 21 insertions, 0 deletions
diff --git a/python/python-gattlib/dont_hardcode_python_versions.patch b/python/python-gattlib/dont_hardcode_python_versions.patch
new file mode 100644
index 0000000000..0e11e85d18
--- /dev/null
+++ b/python/python-gattlib/dont_hardcode_python_versions.patch
@@ -0,0 +1,19 @@
+Matteo Bernardini <ponce@slackbuilds.org>
+---
+Don't hardcode python versions
+
+diff -Naur gattlib-0.20150805.orig/setup.py gattlib-0.20150805/setup.py
+--- gattlib-0.20150805.orig/setup.py 2015-08-05 15:16:56.000000000 +0200
++++ gattlib-0.20150805/setup.py 2018-05-02 09:45:04.625893000 +0200
+@@ -19,9 +19,9 @@
+ glib_libs = [x.strip() for x in glib_libs if x]
+
+ if sys.version_info.major == 3:
+- boost_libs = ["boost_python-py34"]
++ boost_libs = ["boost_python3"+str(sys.version_info.minor)]
+ else:
+- boost_libs = ["boost_python"]
++ boost_libs = ["boost_python2"+str(sys.version_info.minor)]
+ extension_modules = [
+ Extension(
+ 'gattlib',
diff --git a/python/python-gattlib/python-gattlib.SlackBuild b/python/python-gattlib/python-gattlib.SlackBuild
index 0264f52fc1..354003e93e 100644
--- a/python/python-gattlib/python-gattlib.SlackBuild
+++ b/python/python-gattlib/python-gattlib.SlackBuild
@@ -57,6 +57,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+patch -p1 < $CWD/dont_hardcode_python_versions.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \