summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-02-24 12:00:27 +0100
committer Matteo Bernardini2018-06-09 08:41:21 +0200
commit31dcfa6e4a855391fdbb32f37f17eb71d44cd3f7 (patch)
tree29ba60b1fe81c46bba721e1273730a9509a39c43
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-python-certifi.tar.gz
python/python-certifi: Removed (added to Slackware).python-certifi
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/python-certifi/README5
-rw-r--r--python/python-certifi/python-certifi.SlackBuild90
-rw-r--r--python/python-certifi/python-certifi.info10
-rw-r--r--python/python-certifi/slack-desc19
4 files changed, 0 insertions, 124 deletions
diff --git a/python/python-certifi/README b/python/python-certifi/README
deleted file mode 100644
index c7498fdd37..0000000000
--- a/python/python-certifi/README
+++ /dev/null
@@ -1,5 +0,0 @@
-This installable Python package contains a
-CA Bundle that you can reference in your
-Python code.
-
-Optional dependency: python3
diff --git a/python/python-certifi/python-certifi.SlackBuild b/python/python-certifi/python-certifi.SlackBuild
deleted file mode 100644
index 76174511c0..0000000000
--- a/python/python-certifi/python-certifi.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-certifi
-
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-certifi
-SRCNAM=$(printf $PRGNAM | cut -c8-14)
-VERSION=${VERSION:-2018.1.18}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-certifi/python-certifi.info b/python/python-certifi/python-certifi.info
deleted file mode 100644
index 78f2051401..0000000000
--- a/python/python-certifi/python-certifi.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-certifi"
-VERSION="2018.1.18"
-HOMEPAGE="https://pypi.python.org/pypi/certifi/"
-DOWNLOAD="https://pypi.python.org/packages/15/d4/2f888fc463d516ff7bf2379a4e9a552fef7f22a94147655d9b1097108248/certifi-2018.1.18.tar.gz"
-MD5SUM="068fd5c3c690ae47504b3e0bf4e56c4c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-certifi/slack-desc b/python/python-certifi/slack-desc
deleted file mode 100644
index e4121c91ca..0000000000
--- a/python/python-certifi/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-certifi: python-certifi (Python SSL Certificates)
-python-certifi:
-python-certifi: This installable Python package contains a
-python-certifi: CA Bundle that you can reference in your
-python-certifi: Python code.
-python-certifi:
-python-certifi: Homepage: http://python-requests.org
-python-certifi:
-python-certifi:
-python-certifi:
-python-certifi: