summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-04-08 08:14:12 +0200
committer Matteo Bernardini2018-06-09 08:39:56 +0200
commit80e81d0890c601ce15191fd7a6297e8a812858c9 (patch)
tree7cb06e23c2aede3cbd523025e0f408ed306e8ead
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-pip.tar.gz
python/pip: Removed (added to Slackware).pip
...as python-pip Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--python/pip/README24
-rw-r--r--python/pip/pip.SlackBuild71
-rw-r--r--python/pip/pip.info10
-rw-r--r--python/pip/pip.sh9
-rw-r--r--python/pip/slack-desc19
5 files changed, 0 insertions, 133 deletions
diff --git a/python/pip/README b/python/pip/README
deleted file mode 100644
index 6c75c7eea5..0000000000
--- a/python/pip/README
+++ /dev/null
@@ -1,24 +0,0 @@
-pip is a replacement for easy_install (from python-setuptools). It uses
-mostly the same techniques for finding packages, so packages that were
-made easy_installable should be pip-installable as well.
-
-pip is meant to improve on easy_install. Some of the improvements:
-
-- All packages are downloaded before installation. Partially-completed
- installation doesn't occur as a result.
-- Care is taken to present useful output on the console.
-- The reasons for actions are kept track of. For instance, if a package
- is being installed, pip keeps track of why that package was required.
-- Error messages should be useful.
-- The code is relatively concise and cohesive, making it easier to use
- programmatically.
-- Packages don't have to be installed as egg archives, they can be
- installed flat (while keeping the egg metadata).
-- Native support for other version control systems (Git, Mercurial and
- Bazaar).
-- Uninstallation of packages.
-- Simple to define fixed sets of requirements and reliably reproduce a
- set of packages.
-
-pip is complementary with virtualenv, and it is encouraged that you use
-virtualenv to isolate your installation.
diff --git a/python/pip/pip.SlackBuild b/python/pip/pip.SlackBuild
deleted file mode 100644
index 0f28914773..0000000000
--- a/python/pip/pip.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for pip
-
-# Copyright 2012-2018 Audrius Kažukauskas <audrius@neutrino.lt>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=pip
-VERSION=${VERSION:-9.0.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-# Add bash completion file.
-install -D -m 644 $CWD/pip.sh $PKG/usr/share/bash-completion/completions/pip
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pip/pip.info b/python/pip/pip.info
deleted file mode 100644
index ca296f0c81..0000000000
--- a/python/pip/pip.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="pip"
-VERSION="9.0.3"
-HOMEPAGE="https://pip.pypa.io/"
-DOWNLOAD="https://pypi.python.org/packages/c4/44/e6b8056b6c8f2bfd1445cc9990f478930d8e3459e9dbf5b8e2d2922d64d3/pip-9.0.3.tar.gz"
-MD5SUM="b15b33f9aad61f88d0f8c866d16c55d8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
diff --git a/python/pip/pip.sh b/python/pip/pip.sh
deleted file mode 100644
index b9b1ea1477..0000000000
--- a/python/pip/pip.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-# bash completion for pip
-
-_pip_completion()
-{
- COMPREPLY=( $( COMP_WORDS="${COMP_WORDS[*]}" \
- COMP_CWORD=$COMP_CWORD \
- PIP_AUTO_COMPLETE=1 $1 ) )
-}
-complete -o default -F _pip_completion pip
diff --git a/python/pip/slack-desc b/python/pip/slack-desc
deleted file mode 100644
index 443b5a0291..0000000000
--- a/python/pip/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-pip: pip (a better easy_install replacement)
-pip:
-pip: pip is a replacement for easy_install from python-setuptools.
-pip:
-pip: Homepage: https://pip.pypa.io/
-pip:
-pip:
-pip:
-pip:
-pip:
-pip: