summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2017-06-02 18:22:50 +0200
committer Matteo Bernardini2018-06-09 08:35:06 +0200
commit5f1f26d0ae7ce0384a8f3e578894324be23786db (patch)
tree0893930c01587614ed3f7bbfe51181421a7301b8
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-museek+.tar.gz
network/museek+: Removed.museek+
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--network/museek+/README23
-rw-r--r--network/museek+/doinst.sh26
-rw-r--r--network/museek+/museek+.SlackBuild90
-rw-r--r--network/museek+/museek+.info10
-rw-r--r--network/museek+/museek-python.diff44
-rw-r--r--network/museek+/rc.museekd105
-rw-r--r--network/museek+/slack-desc19
7 files changed, 0 insertions, 317 deletions
diff --git a/network/museek+/README b/network/museek+/README
deleted file mode 100644
index 350f3838de..0000000000
--- a/network/museek+/README
+++ /dev/null
@@ -1,23 +0,0 @@
-Museek+ is a file-sharing application for the Soulseek peer-to-peer network,
-written in C++. It's an enhanced version of Hyriand's original Museek
-(see http://museek.thegraveyard.org). It supports chat, transferring files,
-searching, user-management, shares browsing and more. The new features are:
-room searching, interests, buddy-only shares, banlists, icon themes, and
-font/color selecting.
-
-Museek+ consists of museekd (daemon), muscan (shares scanning tool), muscand
-(automated shares scanning tool), musetup (command-line configuration script),
-musetup-gtk (PyGTK configuration app), museeq (QT GUI client), mucous (curses
-python client), murmur (PyGTK client) and museekcontrol (command-line python
-client).
-
-After installing museek+ follow these steps:
- 1) Configure your settings with musetup: server, username, password,
- interface password, download directory, shared directories.
- 2) Run museekd.
- 3) Run museeq, mucous, or museekcontrol.
- 4) Login into museekd via the interface socket or host:port and the
- interface password.
-
-An example init script (rc.museekd) for the museekd daemon is provided.
-Feel free to modify it for your needs. Use it at your own risk.
diff --git a/network/museek+/doinst.sh b/network/museek+/doinst.sh
deleted file mode 100644
index 74a3bd3a48..0000000000
--- a/network/museek+/doinst.sh
+++ /dev/null
@@ -1,26 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-# Keep same perms on rc.museekd.new:
-#if [ -e etc/rc.d/rc.museekd ]; then
-# cp -a etc/rc.d/rc.museekd etc/rc.d/rc.museekd.new.incoming
-# cat etc/rc.d/rc.museekd.new > etc/rc.d/rc.museekd.new.incoming
-# mv etc/rc.d/rc.museekd.new.incoming etc/rc.d/rc.museekd.new
-#fi
-#
-#config etc/rc.d/rc.museekd.new
-
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
-fi
-
diff --git a/network/museek+/museek+.SlackBuild b/network/museek+/museek+.SlackBuild
deleted file mode 100644
index 347b8903bf..0000000000
--- a/network/museek+/museek+.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for museek+
-# Written by Iskar Enev <iskar.enev[@]gmail.com>
-# Currently maintained by B. Watson <yalhcru@gmail.com>
-
-PRGNAM=museek+
-VERSION=${VERSION:-0.2}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# This patch fixes the python modules install path
-# to be architecture aware
-patch -p0 < $CWD/museek-python.diff
-
-cmake -DPREFIX=/usr \
- -DMANDIR=man \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
- -DSWIG_DIR:PATH=`swig -swiglib` \
- -DEVERYTHING=1 \
- -DTRAYICON=1 \
- -DBINRELOC=0
-
-make VERBOSE=1
-make install VERBOSE=1 DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING CREDITS FILES LICENSE README TODO INSTALL \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cat $CWD/rc.museekd > $PKG/usr/doc/$PRGNAM-$VERSION/rc.museekd.new
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/museek+/museek+.info b/network/museek+/museek+.info
deleted file mode 100644
index 8ee1bc1126..0000000000
--- a/network/museek+/museek+.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="museek+"
-VERSION="0.2"
-HOMEPAGE="http://museek-plus.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/museek-plus/museek+-0.2.tar.bz2"
-MD5SUM="66d3eab341e1cd6642f83d329a18c3b5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="libxml++"
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/network/museek+/museek-python.diff b/network/museek+/museek-python.diff
deleted file mode 100644
index 844d17d624..0000000000
--- a/network/museek+/museek-python.diff
+++ /dev/null
@@ -1,44 +0,0 @@
---- murmur/CMakeLists.txt 2008-09-22 11:49:33.000000000 +0300
-+++ murmur/CMakeLists.txt.1 2009-09-01 12:04:34.000000000 +0300
-@@ -25,7 +25,7 @@
- ${PYMURMUR_FILES}
- )
-
--EXECUTE_PROCESS(COMMAND python -c "import sys; import os; print os.path.join('lib', 'python' + str(sys.version_info[0]) + '.' + str(sys.version_info[1]), 'site-packages')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-+EXECUTE_PROCESS(COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1,0,'')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-
- if (NOT sitepackages OR error)
- MESSAGE(FATAL_ERROR "Failed to find Python's site-packages directory" ${sitepackages} ${error})
---- mucous/CMakeLists.txt 2008-09-22 11:49:33.000000000 +0300
-+++ mucous/CMakeLists.txt.1 2009-09-01 12:04:55.000000000 +0300
-@@ -28,7 +28,7 @@
- ${PYMUCOUS_FILES}
- )
-
--EXECUTE_PROCESS(COMMAND python -c "import sys; import os; print os.path.join('lib', 'python' + str(sys.version_info[0]) + '.' + str(sys.version_info[1]), 'site-packages')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-+EXECUTE_PROCESS(COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1,0,'')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-
- if (NOT sitepackages OR error)
- MESSAGE(FATAL_ERROR "Failed to find Python's site-packages directory" ${sitepackages} ${error})
---- python-bindings/CMakeLists.txt 2008-09-22 11:49:33.000000000 +0300
-+++ python-bindings/CMakeLists.txt.1 2009-09-01 12:04:15.000000000 +0300
-@@ -18,7 +18,7 @@
- museek/driver.py
- )
-
--EXECUTE_PROCESS(COMMAND python -c "import sys; import os; print os.path.join('lib', 'python' + str(sys.version_info[0]) + '.' + str(sys.version_info[1]), 'site-packages')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-+EXECUTE_PROCESS(COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1,0,'')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-
- if (NOT sitepackages OR error)
- MESSAGE(FATAL_ERROR "Failed to find Python's site-packages directory" ${sitepackages} ${error})
---- Mucipher/PyMucipher/CMakeLists.txt 2008-10-07 19:58:27.000000000 +0300
-+++ Mucipher/PyMucipher/CMakeLists.txt.1 2009-09-01 12:05:46.000000000 +0300
-@@ -37,7 +37,7 @@
- ${CMAKE_CURRENT_BINARY_DIR}/mucipherc.py
- ${CMAKE_CURRENT_BINARY_DIR}/_mucipherc.so
- )
--EXECUTE_PROCESS(COMMAND python -c "import sys; import os; print os.path.join('lib', 'python' + str(sys.version_info[0]) + '.' + str(sys.version_info[1]), 'site-packages')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-+EXECUTE_PROCESS(COMMAND python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1,0,'')" museek OUTPUT_VARIABLE sitepackages OUTPUT_STRIP_TRAILING_WHITESPACE ERROR_VARIABLE error)
-
- if (NOT sitepackages OR error)
- MESSAGE(FATAL_ERROR "Failed to find Python's site-packages directory" ${sitepackages} ${error})
diff --git a/network/museek+/rc.museekd b/network/museek+/rc.museekd
deleted file mode 100644
index 8c74eb95ab..0000000000
--- a/network/museek+/rc.museekd
+++ /dev/null
@@ -1,105 +0,0 @@
-#!/bin/sh
-#
-# This shell script takes care of starting and stopping museekd.
-
-MUSEEKD=/usr/bin/museekd
-MUSETUP=/usr/bin/musetup
-MUSCAN=/usr/bin/muscan
-MUSOCKET=/tmp/museekd.root
-PIDFILE=/var/run/museekd.pid
-DBDIR=/var/museek
-CONFIG=$DBDIR/museekd.xml
-CHOWNSOCKET=YES
-
-case "$1" in
- start)
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- if [ ! -f $CONFIG ]; then
- echo -n "Starting Museek Setup"
- echo
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- $MUSETUP $CONFIG
- echo
- fi
- if [ -f $PIDFILE ]; then
- echo -n "Museek Daemon already running (or zombie pid file in /var/run/)"
- echo
- exit
- fi
- echo -n "Starting Museek Daemon"
- $MUSEEKD -c $CONFIG &>/dev/null &
- PID="$!"
- sleep 2
- if kill -0 $PID # pid check
- then
- if [ $CHOWNSOCKET = YES ];
- then
- if [ -e $MUSOCKET ]; then chmod 666 $MUSOCKET
- # access the museekd socket from other users, may be a security risk on multiuser systems
- fi
- fi
- echo $PID > $PIDFILE
- echo
- else
- echo -n "Museekd isn't starting up properly. Check your Config file, \nor run 'museekd -c /var/museek/museekd.xml' for verbose messages."
- echo
- fi
- ;;
- stop)
- echo -n "Stopping Museek Daemon"
- echo
- if [ -f $PIDFILE ]; then
- kill -15 $(cat $PIDFILE) &>/dev/null
- rm $PIDFILE
- else
- echo -n "Museek Daemon not running"
- echo
- exit
- fi
- ;;
- reconnect)
- if [ -f $PIDFILE ]; then
- echo -n "Attempting to reconnect Museekd to the Server"
- kill -ALRM $(cat $PIDFILE) &>/dev/null
- echo
- fi
- ;;
- restart)
- $0 stop
- sleep 3
- $0 start
- ;;
- rescan)
- echo -n "Starting Muscan, rescanning shared files"
- echo
- $MUSCAN -c $CONFIG -r -v
- echo
- $0 reload
- ;;
- setup)
- echo -n "Starting Museek Setup"
- echo
- if [ ! -d $DBDIR ]; then
- mkdir $DBDIR
- fi
- $MUSETUP $CONFIG
- echo
- ;;
- reload)
- if [ -f $PIDFILE ]; then
- echo -n "Reloading Museek Daemon to update Shares"
- kill -HUP $(cat $PIDFILE)
- echo
- else
- echo -n "Museek Daemon not running, can't reload shares"
- echo
- fi
- ;;
- *)
- echo "usage: $0 {start|stop|restart|rescan|reconnect|setup|reload}"
- echo -n
-esac
diff --git a/network/museek+/slack-desc b/network/museek+/slack-desc
deleted file mode 100644
index 58f0d98ace..0000000000
--- a/network/museek+/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-museek+: museek+ (file-sharing application)
-museek+:
-museek+: Museek+ is a file-sharing application for the Soulseek p2p network,
-museek+: written in C++. It's an enhanced version of Hyriand's original Museek
-museek+: (http://museek.thegraveyard.org). It supports chat, transferring
-museek+: files, searching, user-management, sharing, banlists, interests
-museek+: and more. Museek+ consists of museekd (daemon), muscan (shares
-museek+: scanning tool), muscand (automated shares scanning tool), musetup
-museek+: (command-line configuration script), musetup-gtk (PyGTK configuration
-museek+: app), museeq (QT GUI client), mucous (curses python client),
-museek+: museekcontrol (command-line python client) and murmur (PyGTK client).