summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-04-14 16:09:07 +0200
committer Matteo Bernardini2018-06-09 08:29:13 +0200
commit0ce868f8d8526634007340417c792adc06a31421 (patch)
tree57e202313ca7de37ecfc02769cfd48e5bfa4b215
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-lbzip2.tar.gz
system/lbzip2: Removed (added to Slackware).lbzip2
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--system/lbzip2/README2
-rw-r--r--system/lbzip2/lbzip2.SlackBuild121
-rw-r--r--system/lbzip2/lbzip2.info10
-rw-r--r--system/lbzip2/slack-desc19
4 files changed, 0 insertions, 152 deletions
diff --git a/system/lbzip2/README b/system/lbzip2/README
deleted file mode 100644
index 2092f0ebfb..0000000000
--- a/system/lbzip2/README
+++ /dev/null
@@ -1,2 +0,0 @@
-lbzip2 is a multi-threaded bzip2/bunzip2 filter that doesn't depend on the
-lseek() system call and so isn't restricted to regular files.
diff --git a/system/lbzip2/lbzip2.SlackBuild b/system/lbzip2/lbzip2.SlackBuild
deleted file mode 100644
index 801213a810..0000000000
--- a/system/lbzip2/lbzip2.SlackBuild
+++ /dev/null
@@ -1,121 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for lbzip2
-#
-# Copyright 2009-2010 Erik W. Hanson, Minneapolis, MN, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by B. Watson <yalhcru@gmail.com>.
-
-# 20170302 bkw: use long-format github URL
-
-# 20150519 bkw:
-# - took over maintenance
-# - bump VERSION to 2.5
-# - add gnulib dependency
-# - make VERSION respect environment
-# - clean up slack-desc
-
-PRGNAM=lbzip2
-VERSION=${VERSION:-2.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -eu
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Upstream says automake-1.14 is required, but our
-# 1.11.5 works fine if we change the version check.
-sed -i '/^AM_INIT_AUTOMAKE/s,1\.14,1.11.5,' configure.ac
-
-sh build-aux/autogen.sh
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-gzip $PKG/usr/man/man1/$PRGNAM.1
-
-# The other man pages just source lbzip2.1. Make them
-# symlinks instead (easier to deal with).
-for i in lbunzip2 lbzcat; do
- rm -f $PKG/usr/man/man1/$i.1
- ln -s $PRGNAM.1.gz $PKG/usr/man/man1/$i.1.gz
-done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ALGORITHM AUTHORS COPYING ChangeLog* NEWS README THANKS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/system/lbzip2/lbzip2.info b/system/lbzip2/lbzip2.info
deleted file mode 100644
index c1ccd5d21a..0000000000
--- a/system/lbzip2/lbzip2.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lbzip2"
-VERSION="2.5"
-HOMEPAGE="https://github.com/kjn/lbzip2/"
-DOWNLOAD="https://github.com/kjn/lbzip2/archive/v2.5/lbzip2-2.5.tar.gz"
-MD5SUM="288e404f325d9073bdc80759cae30adc"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="gnulib"
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
diff --git a/system/lbzip2/slack-desc b/system/lbzip2/slack-desc
deleted file mode 100644
index fb3286dd7e..0000000000
--- a/system/lbzip2/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-lbzip2: lbzip2 (a pthreads-based parallel bzip2/bunzip2)
-lbzip2:
-lbzip2: Lbzip2 is a Pthreads-based parallel bzip2/bunzip2 filter passable to
-lbzip2: GNU tar with the --use-compress-program option. It isn't restricted
-lbzip2: to regular files on input, nor output.
-lbzip2:
-lbzip2:
-lbzip2:
-lbzip2:
-lbzip2:
-lbzip2: