summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini2018-02-24 07:41:29 +0100
committer Matteo Bernardini2018-06-09 07:46:14 +0200
commite42cbdbff248be6591ee91dcaeb233f634c03436 (patch)
treedacee5ddc2c0f43e5b1e1d578fc3710a5056a5e1
parent81c344443219574587ae3d6bccb8f19c1bd346af (diff)
downloadold.slackbuilds-audacious-ffmpeg.tar.gz
audio/audacious-ffmpeg: Removed (added to Slackware).audacious-ffmpeg
Now part of the package audacious-plugins Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--audio/audacious-ffmpeg/README4
-rw-r--r--audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild106
-rw-r--r--audio/audacious-ffmpeg/audacious-ffmpeg.info10
-rw-r--r--audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff8
-rw-r--r--audio/audacious-ffmpeg/slack-desc19
5 files changed, 0 insertions, 147 deletions
diff --git a/audio/audacious-ffmpeg/README b/audio/audacious-ffmpeg/README
deleted file mode 100644
index 04da987f9f..0000000000
--- a/audio/audacious-ffmpeg/README
+++ /dev/null
@@ -1,4 +0,0 @@
-audacious-ffmpeg (ffmpeg Decoder Plugin used by the Audacious player)
-
-This plugin adds all audio ffmpeg decoders to the Audacious media
-player that comes with Slackware stock packages
diff --git a/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild b/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild
deleted file mode 100644
index f45b5c764f..0000000000
--- a/audio/audacious-ffmpeg/audacious-ffmpeg.SlackBuild
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for audacious-ffmpeg
-
-# Copyright 2016 Johannes Schoepfer, Herrenberg, BW; Germany
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=audacious-ffmpeg
-VERSION=${VERSION:-3.7.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=audacious-plugins
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
- ARCHOPTS="--disable-sse2"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- ARCHOPTS="--disable-sse2"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- ARCHOPTS=""
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- ARCHOPTS=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.bz2
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Patch Makefile to build only aac plugin
-patch -p1 <$CWD/patches/enable_only_ffmpeg_plugin.diff || exit 1
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --disable-aac \
- --program-prefix= \
- --program-suffix= \
- ${ARCHOPTS} \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING INSTALL $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/audacious-ffmpeg/audacious-ffmpeg.info b/audio/audacious-ffmpeg/audacious-ffmpeg.info
deleted file mode 100644
index 4d49914a64..0000000000
--- a/audio/audacious-ffmpeg/audacious-ffmpeg.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="audacious-ffmpeg"
-VERSION="3.7.2"
-HOMEPAGE="https://audacious-media-player.org/"
-DOWNLOAD="https://distfiles.audacious-media-player.org/audacious-plugins-3.7.2.tar.bz2"
-MD5SUM="6ae2f17885897e717b8bbafc32858e2f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="ffmpeg"
-MAINTAINER="Johannes Schoepfer"
-EMAIL="slackbuilds[at]schoepfer[dot]info"
diff --git a/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff b/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff
deleted file mode 100644
index feb3fab813..0000000000
--- a/audio/audacious-ffmpeg/patches/enable_only_ffmpeg_plugin.diff
+++ /dev/null
@@ -1,8 +0,0 @@
---- audacious-plugins-3.6.1/Makefile.ORIG 2015-04-04 02:02:06.000000000 +0200
-+++ audacious-plugins-3.6.1/Makefile 2015-04-23 19:59:48.072721987 +0200
-@@ -1,4 +1,4 @@
--SUBDIRS = src po
-+SUBDIRS = src/ffaudio
-
- DISTCLEAN = buildsys.mk config.h config.log config.status extra.mk
-
diff --git a/audio/audacious-ffmpeg/slack-desc b/audio/audacious-ffmpeg/slack-desc
deleted file mode 100644
index e14234a198..0000000000
--- a/audio/audacious-ffmpeg/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-audacious-ffmpeg: audacious-ffmpeg (ffmpeg Decoder Plugin)
-audacious-ffmpeg:
-audacious-ffmpeg: This plugin adds all audio ffmpeg decoders to the Audacious media
-audacious-ffmpeg: player that comes with Slackware stock packages
-audacious-ffmpeg:
-audacious-ffmpeg: Homepage: https://audacious-media-player.org/
-audacious-ffmpeg:
-audacious-ffmpeg:
-audacious-ffmpeg:
-audacious-ffmpeg:
-audacious-ffmpeg: