summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Christoph Willing2013-04-13 16:57:12 +0200
committer Robby Workman2013-04-16 00:21:03 +0200
commit12d66761691394485a5fe5729a40cea9c05ab23b (patch)
treea0283db6c1257ec0a239f9a6c00e97fc8d231100
parent4683b86f30713766580e56fa3e54bebd6c1e5b52 (diff)
downloadold.slackbuilds-12d66761691394485a5fe5729a40cea9c05ab23b.tar.gz
python/pymongo: Added (Python Driver/Tools for mongodb)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
-rw-r--r--python/pymongo/README6
-rw-r--r--python/pymongo/pymongo.SlackBuild93
-rw-r--r--python/pymongo/pymongo.info10
-rw-r--r--python/pymongo/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/python/pymongo/README b/python/pymongo/README
new file mode 100644
index 0000000000..cfa106b153
--- /dev/null
+++ b/python/pymongo/README
@@ -0,0 +1,6 @@
+The PyMongo distribution contains tools for interacting with MongoDB
+database from Python. The bson package is an implementation of
+the BSON format for Python (http://bsonspec.org). The pymongo
+package is a native Python driver for MongoDB. The gridfs package
+is a gridfs implementation on top of pymongo.
+(http://www.mongodb.org/display/DOCS/GridFS+Specification)
diff --git a/python/pymongo/pymongo.SlackBuild b/python/pymongo/pymongo.SlackBuild
new file mode 100644
index 0000000000..a428feaf35
--- /dev/null
+++ b/python/pymongo/pymongo.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for pymongo
+
+# Copyright 2013 Christoph Willing, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pymongo
+VERSION=${VERSION:-2.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ev
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+#chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Build & install
+python setup.py install --root=$PKG
+python setup.py doc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
+cp -a \
+ LICENSE README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ doc/_build/$VERSION/* \
+ $PKG/usr/doc/$PRGNAM-$VERSION/html/
+rm -rf $PKG/usr/doc/$PRGNAM-$VERSION/html/_sources
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/pymongo/pymongo.info b/python/pymongo/pymongo.info
new file mode 100644
index 0000000000..a17ee06a09
--- /dev/null
+++ b/python/pymongo/pymongo.info
@@ -0,0 +1,10 @@
+PRGNAM="pymongo"
+VERSION="2.4.2"
+HOMEPAGE="https://pypi.python.org/pypi/pymongo"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pymongo/pymongo-2.4.2.tar.gz"
+MD5SUM="102a00761067d0c0a6b91f33840d811e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="Sphinx Pygments"
+MAINTAINER="Christoph Willing"
+EMAIL="c.willing@uq.edu.au"
diff --git a/python/pymongo/slack-desc b/python/pymongo/slack-desc
new file mode 100644
index 0000000000..9a5631452d
--- /dev/null
+++ b/python/pymongo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pymongo: pymongo (Python Driver/Tools for mongodb)
+pymongo:
+pymongo: The PyMongo distribution contains tools for interacting with MongoDB
+pymongo: database from Python. The bson package is an implementation of
+pymongo: the BSON format for Python (http://bsonspec.org). The pymongo
+pymongo: package is a native Python driver for MongoDB. The gridfs package
+pymongo: is a gridfs implementation on top of pymongo.
+pymongo: (http://www.mongodb.org/display/DOCS/GridFS+Specification)
+pymongo:
+pymongo:
+pymongo: